Tłumaczenie plików Trados TTX w memoQ

Z mediawiki

Jak tłumaczyć pliki Tradosa w memoQ?

Cel: pliki otrzymane w formacie DOC (plik do tłumaczenia) i TMW (wew. format pamięci tłumaczeniowych programu Trados) przetłumaczyć w memoQ i dostarczyć klientowi dwujęzyczny plik TTX, który wygląda, jak tłumaczony w programie Trados, oraz zaktualizowaną pamięć tłumaczeniową w formacie TMX.

Film, na którym widać całą procedurę znajduje się tu: youtu.be/ezJA15lbwMg. Polecam włączyć pełny ekran, ponieważ w oknie nazwy elementów menu programu mogą być niewidoczne.

  1. Otwórz pamięć TMW w programie Translator’s Workbench. W tym celu po uruchomieniu programu Workbench kliknij menu File -> Open i wybierz plik TMW. W dolnej części okna otwierania nie zapomnij zaznaczyć opcji Exclusive (jeśli jest ona widoczna).
  2. Otwórz plik DOC w programie Tageditor (jeden ze składników Tradosa – dostępny po zainstalowaniu Tradosa; w menu Start w systemie Windows wybierz pozycję SDL International i podążaj dalej do momentu wyświetlenia pozycji Translator’s Workbench ORAZ Tageditor) i zapisz jako TTX (wew. format plików programu Trados). Jest to krok opcjonalny, w przypadku gdy klient nie dostarczył pliku w Tradosowym formacie TTX, a gotowe tłumaczenie chce właśnie w tym formacie. Jeśli klient dostarczył plik TTX, to nie trzeba go otwierać w programie Tageditor.
  3. Przeanalizuj plik TTX przeznaczony do tłumaczenia. W tym celu w programie Workbench wybierz menu Tools -> Analyse i kliknij przycisk Analyse (w prawym górnym rogu okna). Analizę porównaj z analizą dostarczoną przez klienta (jeśli jest). W pliku analizy klienta sprawdź, czy nazwa otrzymanej pamięci tłumaczeniowej i przeanalizowanego za jej pomocą pliku są zgodne z pamięcią tłumaczeniową i plikiem otrzymanym w paczce od klienta.Jeśli klient nie dostarczył analizy, w wiadomości e-mail poproś o plik analizy.
  4. W programie Translator’s Workbench wyeksportuj pamięć TMW do formatu TMX. W tym celu w programie Workbench kliknij menu File -> Export, w kolejnym oknie dialogowym kliknij przycisk OK, a w następnym zapisz plik w formacie TMX 1.4b. Wprowadź dowolną, zrozumiałą dla siebie nazwę pliku.
  5. W programie Translator’s Workbench wykonaj pretranslację pliku TTX. W tym celu kliknij menu Tools -> Translate i do lewego panelu dodaj swój plik TTX. Zaznacz opcje zgodnie z poniższym rysunkiem. W przypadku opcji Log File ustawienie może być i powinno być inne - dowolnie wybrane przez użytkownika.
    Ttx_ustawienia_trados.jpg‎
  6. W programie memoQ utwórz pusty projekt, pustą pamięć i pusty glosariusz. Lub dodaj te elementy do już istniejącego projektu przeznaczonego dla tego klienta.
  7. Do projektu dodaj plik TTX przeznaczony do tłumaczenia. W tym celu przeciągnij i upuść plik TTX do okna memoQ.
  8. Zaimportuj pamięć w formacie TMX. W tym celu w panelu Project home wybierz pozycję Translation memories. Kliknij opcję Import from TMX/CSV. Następnie w oknie Translation memory TMX import settings upewnij się, że języki Source i Target są zgodne z zamierzonymi i kliknij przycisk OK.
  9. Przenalizuj plik TTX za pomocą funkcji statystyki w programie memoQ i porównaj liczbę segmentów z analizą w programie Translator’s Workbench. Liczba słów w analizie Tradosa i memoQ może się odrobinę różnić (co jest spowodowane różnym sposobem zliczania słów zawierających apostrofy i dywizy), jednak liczby segmentów muszą być identyczne w obydwu programach.
  10. Wykonaj tłumaczenie w programie memoQ.
  11. Wyeksportuj plik TTX z programu memoQ. W tym celu kliknij kartę Project home i wybierz opcję eksportu Export (stored path) lub opcje Export (dialog) i wybierz katalog, do którego zostanie wyeksportowany plik TTX. Pamiętaj, aby upewnić się, że nazwa przetłumaczonego pliku jest DOKŁADNIE TAKA SAMA, jak pliku przysłanego przez klienta!!!
  12. Wyeksportuj pamięć z programu memoQ w postaci pliku TMX. W tym celu na panelu bocznym Project home w memoQ wybierz pozycję Translation memories. Kliknij żądaną pamięć tłumaczeniową i w dolnej części okna wybierz opcję Export to TMX i wybierz katalog, do którego zostanie wyeksportowana pamięć tłumaczeniowa w postaci pliku TMX.
  13. Otwórz przetłumaczony plik TTX w programie Tageditor, aby sprawdzić, czy Tageditor go rozpoznaje.
  14. Opcjonalnie zapisz plik TTX w programie Tageditor.
  15. Gotowe.
Osobiste